phpmyadmin no funciona después de que lo instalé

48

Estoy usando ubuntu-11.04 .

Seguí estos pasos en este sitio:

Hasta ahora, mi apache2, php y mysql funcionan bien, excepto phpmyadmin ... Siempre que ejecuto esto:

http://localhost/phpmyadmin/

Recibo este error en mi navegador:

  

No encontrado

     

La URL solicitada / phpmyadmin / no se encontró en este servidor.

     

Apache / 2.2.17 (Ubuntu) Servidor en el puerto localhost 80

    
pregunta Moron 01.08.2011 - 02:21

10 respuestas

103

Lea esta sección en Ubuntu wiki. Tendrá que configurar su apache2.conf para que phpMyAdmin funcione.

gksu gedit /etc/apache2/apache2.conf

Luego agregue la siguiente línea al final del archivo.

Include /etc/phpmyadmin/apache.conf

Luego reinicia apache

/etc/init.d/apache2 restart
    
respondido por el JohanSJA 01.08.2011 - 03:12
13

Intentó varias formas diferentes.

Finalmente, esto de documentación de ubuntu , funcionó para mí:

sudo ln -s /etc/phpmyadmin/apache.conf /etc/apache2/conf-available/phpmyadmin.conf
sudo a2enconf phpmyadmin
sudo service apache2 reload
    
respondido por el sangharsh 22.09.2015 - 09:29
5

Ubuntu 16.04

Después de instalar y configurar el usuario y la contraseña en mysql y phpmyadmin, ejecute el siguiente comando

sudo apt install php-gettext

Trabajó para mí ...

Editar1 Si solo necesita apache, phPmyAdmin y MySql solo para un entorno de aplicación web, entonces sugiero, por ejemplo, que instale los tres para usted y esté listo para comenzar. Aquí está el enlace

Instaladores y descargas de XAMPP | Amigos de Apache

    
respondido por el Rajat Verma 03.07.2016 - 06:52
3

¡No entres en pánico! Simplemente ejecute el siguiente código con permiso de root en el terminal

sudo ln -s /usr/share/phpmyadmin /var/www
    
respondido por el Hardik Thaker 13.02.2013 - 13:59
1

Me enfrenté al mismo problema, lo solucioné al ejecutar sudo dpkg-reconfigure phpmyadmin

dar nuevo nombre de usuario y contraseña

    
respondido por el Tachyons 13.02.2013 - 14:10
0

Debe encontrar dónde se encuentra phpmyadmin , p. %código%, algunos devolverán la ubicación, como locate phpmyadmin .

Luego puedes enlazarlo de la siguiente manera: /usr/share/phpmyadmin

Iniciando Ubuntu 14.04 y arriba, sudo ln -s /usr/share/phpmyadmin /var/www ya no funciona, en cambio /var/www . por ejemplo, /var/www/html

Referencia: ¿Dónde ubicar mi sitio web local comenzando con la versión 2.4.7 de apache2?

    
respondido por el Arman Ortega 21.06.2015 - 16:13
0
sudo sed -i '$ a\Include /etc/phpmyadmin/apache.conf' /etc/apache2/apache2.conf && sudo service apache2 restart && sudo apt-get install php-gettext'

Probado y funciona. Correr eso debería resolverlo para cualquiera que quiera un trazador de líneas 1.

    
respondido por el Robert Pounder 30.11.2016 - 16:06
0

Probé todos los métodos anteriores y no funcionaron para mí. Finalmente este funcionó.

Abre la terminal y cambia a superusuario usando el comando: sudo su

Después de instalar phpmyadmin usando las instrucciones dadas en enlace , abre /etc/apache2/conf-available .

Encontrarás un archivo llamado phpmyadmin.conf . Cópialo a /etc/apache2/conf-enabled . O simplemente use el comando

sudo cp /etc/apache2/conf-available /etc/apache2/conf-enabled

Reinicia Apache2 ( sudo service apache2 restart ) y luego abre el enlace localhost / phpmyadmin en un navegador.

    
respondido por el abeginner 23.02.2017 - 21:22
0

finalmente este trabajo para ubuntu 14.04 LTS

sudo ln -s /etc/phpmyadmin/apache.conf /etc/apache2/conf-available/phpmyadmin.conf
sudo ln -s /usr/share/phpmyadmin /var/www/html/phpmyadmin
sudo service apache2 restart

ahora escribe localhost/phpmyadmin en el navegador web.

    
respondido por el shamsh nezam 12.10.2017 - 06:59
-3

Estaba enfrentando el mismo problema.

Primero verifique si el directorio llamado /usr/share/phpmyadmin/ existe. Si lo hace, simplemente muévelo a /var/www/phpmyadmin ejecutando este comando:

mv /usr/share/phpmyadmin /var/www/phpmyadmin

Abra su navegador y abra http://localhost/phpmyadmin . Ahora debería funcionar.

    
respondido por el Mariyah 26.07.2012 - 06:06

Lea otras preguntas en las etiquetas