¿Cómo hago para que las teclas F funcionen en bybu, para el comandante de medianoche (mc), htop, etc.?

44

Utilizo byobu con el backend de tmux en mi servidor 12.04. Me gustaría utilizar las teclas de acceso directo del comandante de medianoche, pero las teclas F no funcionan.

He visto algunas publicaciones sobre los problemas aquí:

pero están desactualizados y no parecen funcionar para versiones más nuevas de bybu. ¿Cómo puedo evitar esto o usar MC de una manera que funcione mejor?

    
pregunta Jorge Castro 05.06.2012 - 02:37

3 respuestas

64

Puede activar / desactivar fácilmente el uso de las teclas F dentro de Byobu (tmux) presionando cualquiera de los siguientes:

  • shift - F12 (en tmux)

  • ctrl - a - ! (en pantalla)

Revelación completa: soy el autor y mantenedor de Byobu.

    
respondido por el Dustin Kirkland 08.06.2012 - 15:47
8

En comandante de medianoche para activar la tecla F puede, por ejemplo, en lugar de F2 :

  • Presione Alt + 2 .
  • Presione ESC , 2 (uno tras otro).

Quizás sea más conveniente que cambiar usando:

  • shift - F12 (en tmux, por defecto en bybu)

  • ctrl - a - ! (en pantalla)

respondido por el takeshin 06.10.2014 - 12:11
3

Ja, un hombre según mi propio corazón:)

Respuesta corta: agregue my ppa ( ppa:izx/private ) y update byobu (o instale manualmente el debutante). Byobu usará por defecto screen como backend con el comportamiento de la tecla F restaurado al antiguo estilo 4.x.

Respuesta larga: usa byobu-select-backend para cambiar a screen si no lo has hecho aún, y agrega la línea $BYOBU_PREFIX/share/byobu/keybindings/f-keys.screen.disable después de la línea $BYOBU_PREFIX/share/byobu/keybindings/f-keys.screen en /usr/share/byobu/keybindings/common .

Parche completo:

+++ byobu-5.17/usr/share/byobu/keybindings/common
@@ -1 +1,3 @@
 source $BYOBU_PREFIX/share/byobu/keybindings/f-keys.screen
+source $BYOBU_PREFIX/share/byobu/keybindings/f-keys.screen.disable
+
--- byobu-5.17.orig/etc/byobu/backend
+++ byobu-5.17/etc/byobu/backend
@@ -1,4 +1,4 @@
 # BYOBU_BACKEND can currently be "screen" or "tmux"
 # Override this on a per-user basis by editing "$BYOBU_CONFIG_DIR/backend"
 # or by launching either "byobu-screen" or "byobu-tmux" instead of "byobu".
-#BYOBU_BACKEND="tmux"
+BYOBU_BACKEND="screen"
    
respondido por el ish 05.06.2012 - 03:30

Lea otras preguntas en las etiquetas